• 加入收藏
    股票公式网
    扫码关注公众号更多学习资讯

    您所在地位置:首页> 公式指标 > 选股公式 > 真命掌握缠论线段中枢主图下载

    真命掌握缠论线段中枢主图下载

    时间:2020-05-06 10:46:02 阅读:1557 编辑:

    真命掌握缠论线段中枢主图源码下载:

    N1:=10;

    N2:=10;

    老笔:=1;

    DISP:=2;

    K:=1;

    MA7:MA(C,7),colorwhite;

    MA77:MA(C,77),colorlired;

    MA177:MA(C,177),colorliblue;

    P1:=PEAK(1,K*N1,1);

    P2:=PEAK(1,K*N1,2);

    G:=MA(C,5);

    D:=MA(C,10);

    HH:=REF(H,5)=HHV(H,11);

    LL:=REF(L,5)=LLV(L,11);

    WP1:=PEAKBARS(1,K*N1,1);

    WP2:=PEAKBARS(1,K*N1,2);

    FG01:=BACKSET(HH,6)>BACKSET(HH,5);

    FD01:=BACKSET(LL,6)>BACKSET(LL,5);

    T1:=TROUGH(2,K*N2,1);

    T2:=TROUGH(2,K*N2,2);

    FG02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND G>D,FG01,

    IF(BARSLAST(FD01)>BARSLAST(FG01),FG01,0));

    FD02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND D>G,FD01,

    IF(BARSLAST(FG01)>BARSLAST(FD01),FD01,0));

    WT1:=TROUGHBARS(2,K*N2,1);

    WT2:=TROUGHBARS(2,K*N2,2);

    FG0:=FG02 AND H=HHV(H,BARSLAST(FD02));

    FD0:=FD02 AND L=LLV(L,BARSLAST(FG02));

    TJ1:=P1>T1 AND P2>T2 ;

    ZD:=MAX(T1,T2);

    ZG:=MIN(P1,P2);

    GP:IF(FG0,H,DRAWNULL),CIRCLEDOT,colorcyan;

    DP:IF(FD0,L,DRAWNULL),CIRCLEDOT,colorcyan;

    LL:=MIN(T1,T2);//www.CHNmoney.com

    HH:=MAX(P1,P2);

    GQ:=L>REF(H,1) AND DAY!=REF(DAY,1);

    DQ:=H<REF(L,1) AND DAY!=REF(DAY,1);

    TJ2:=FILTER(ZG>ZD,2);

    TJ3:=ZG=REF(ZG,BARSLAST(TJ2)) OR ZD=REF(ZD,BARSLAST(TJ2));

    TJ4:=TJ1 AND TJ2 AND NOT(TJ3);

    GQL:=REF(L,BARSLAST(GQ));

    DQH:=REF(H,BARSLAST(DQ));

    FGH:=REF(H,BARSLAST(FG0));

    FGL:=REF(L,BARSLAST(FG0));

    TJ5:=BETWEEN(ZD,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));

    TJ6:=BETWEEN(ZG,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));

    FGH1:=REF(H,BARSLAST(FG0)+1);

    FGL1:=REF(L,BARSLAST(FG0)+1);

    FGH2:=REF(H,BARSLAST(FG0)+2);

    FGL2:=REF(L,BARSLAST(FG0)+2);

    TJ7:=ZG>REF(ZG,REF(BARSLAST(TJ4),1)) AND ZD<REF(ZD,REF(BARSLAST(TJ4),1));

    TJ8:=TJ4 AND NOT(TJ5 OR TJ6 OR TJ7);

    FDH:=REF(H,BARSLAST(FD0));

    FDL:=REF(L,BARSLAST(FD0));

    FDH1:=REF(H,BARSLAST(FD0)+1);

    FDL1:=REF(L,BARSLAST(FD0)+1);

    FDH2:=REF(H,BARSLAST(FD0)+2);

    FDL2:=REF(L,BARSLAST(FD0)+2);

    ZSD:=IF(TJ8,ZD,REF(ZD,1)),coloryellow;

    ZSG:=IF(TJ8,ZG,REF(ZG,1)),colormagenta;

    FGZH:=IF(FGL<=FGL1,FGH2,FGH1);

    FGZL:=IF(FGH1<FGL,FGL,IF(FGL<=FGL1,FGL2,FGL1));

    FDZH:=IF(FDL1>FDH,FDH,IF(FDH>=FDH1,FDH2,FDH1));

    FDZL:=IF(FDH>=FDH1,FDL2,FDL1);

    ZSH:=IF(TJ8,HH,REF(HH,1)),colorblue;

    ZSL:=IF(TJ8,LL,REF(LL,1)),colorgreen;

    FG1:=FGH>FDZH AND FG0;

    FD1:=FDL<FGZL AND FD0;

    FG:=FG1 AND FGH>FDH AND FGL>FDL AND FGL1>FDL;

    FD:=FD1 AND FDL<FGL AND FDH<FGH AND FDH1<FGH;

    STICKLINE(TJ8,ZSH,ZSL,0,-1),colormagenta;

    STICKLINE(TJ8,ZSD,ZSG,IF(DISP=1,3,0),1),colormagenta;

    BH0:=(H<=REF(H,1) AND L>=REF(L,1)) OR (H>=REF(H,1) AND L<=REF(L,1));

    BHG:=COUNT(BH0,BARSLAST(FD0));

    BHD:=COUNT(BH0,BARSLAST(FG0));

    BGQ:=COUNT(GQ,BARSLAST(FD0));

    BDQ:=COUNT(DQ,BARSLAST(FG0));

    DRAWTEXT(DISP=2,ZSH,''),colorwhite;

    BK0:=IF(BHG>0,BHG+2+老笔,IF(BHD,BHD+2+老笔,3));

    BK:=IF(BGQ,BK0-BGQ,IF(BDQ,BK0-BDQ,BK0));

    中枢高:ZSG,colormagenta;

    POLYLINE(DISP=2,REF(ZSG,BARSLAST(TJ8))),CIRCLEDOT,colormagenta;

    中枢低:ZSD,coloryellow;

    G1X:=(FG AND BARSLAST(FD)>BK);

    D1X:=(FD AND BARSLAST(FG)>BK);

    POLYLINE(DISP=2,REF(ZSD,BARSLAST(TJ8))),CIRCLEDOT,coloryellow;

    中枢最高:ZSH,colorred;

    G1:=(FG0 AND REF(H,BARSLAST(FG0))>=REF(H,BARSLAST(G1X)) AND BARSLAST(D1X)>BARSLAST(G1X))

    OR (FG1 AND COUNT(GQ,BARSLAST(FD1))>0 AND REF(H,BARSLAST(FG1))>REF(H,BARSLAST(G1X)));

    D1:=(FD0 AND REF(L,BARSLAST(FD0))<=REF(L,BARSLAST(D1X)) AND BARSLAST(G1X)>BARSLAST(D1X))

    OR (FD1 AND COUNT(DQ,BARSLAST(FG1))>0 AND REF(L,BARSLAST(FD1))<REF(H,BARSLAST(D1X)));

    G1H:=IF(BARSLAST(D1)>BARSLAST(G1),REF(H,BARSLAST(G1)),REF(H,BARSLAST(D1))),;

    POLYLINE(DISP=2,REF(ZSH,BARSLAST(TJ8))),POINTDOT,colorred;

    中枢最低:ZSL,colorgreen;

    D1L:=IF(BARSLAST(G1)>BARSLAST(D1),REF(L,BARSLAST(D1)),REF(L,BARSLAST(G1)));

    G2:=G1 AND H=HHV(G1H,BARSLAST(D1)+1) AND H>REF(H,1) AND BARSLAST(D1)>BARSLAST(G1);

    D2:=D1 AND L=LLV(D1L,BARSLAST(G1)+1) AND L<REF(L,1) AND BARSLAST(G1)>BARSLAST(D1);

    POLYLINE(DISP=2,REF(ZSL,BARSLAST(TJ8))),POINTDOT,colorgreen;

    MA5:MA(CLOSE,5),COLORFF00FF,Linethick1;

    G3:=G2 OR (FG0 AND REF(H,BARSLAST(FG0))>REF(H,BARSLAST(G2)) AND BARSLAST(D2)>BARSLAST(G2));

    D3:=D2 OR (FD0 AND REF(L,BARSLAST(FD0))<REF(L,BARSLAST(D2)) AND BARSLAST(G2)>BARSLAST(D2));

    GPB:IF(G1X,H,DRAWNULL),CIRCLEDOT,coloryellow;

    DPB:IF(D1X,L,DRAWNULL),CIRCLEDOT,coloryellow;

    命真好:=MA5>REF(MA5,1);

    命真坏:=MA5<REF(MA5,1);

    NN:=G3;

    UU:=D3;

    L1:DRAWLINE(UU,L,NN, H,0),colorligreen;

    L2:DRAWLINE(NN,H,UU, L,0),colorligreen;

    DRAWNUMBER(L1 AND L2 AND NN ,H,H),colorlired;

    DRAWNUMBER(L1 AND L2 AND UU ,L,L),colorlimagenta;

    PARTLINE(MA5,命真好,coloryellow,命真坏,colorblue,MA5,COLORFF00FF),linethick3;

    真命掌握缠论线段中枢主图

    热门标签:

    免责声明:本站不推荐任何股票,不收会员,站内的广告不代表股票公式网的观点,目的在于传播更多信息,由此引起的一切法律责任均与本网无关,专注为大众提供股票指标、选股公式、股票入门、开户等信息,股票公式网—专业的股票学习网站!股市有风险 投资需谨慎。