• 加入收藏
    股票公式网

    您所在地位置:首页> 公式指标 > 选股公式 > 多重优化DMI指标下载

    多重优化DMI指标下载

    时间:2020-05-23 20:42:01 阅读:1144 编辑:

    多重优化DMI指标源码下载:

     N:=21;

    M:=6;

    M1:=20;

    TR1:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);

    HD :=HIGH-REF(HIGH,1);

    LD :=REF(LOW,1)-LOW;

    DMP:=EMA(IF(HD>0 AND HD>LD,HD,0),N);

    DMM:=EMA(IF(LD>0 AND LD>HD,LD,0),N);

    PDI:= DMP*100/TR1;

    MDI:= DMM*100/TR1;

    ADX: EMA((PDI-MDI)/(MDI+PDI)*100,M)*2;

    ADXR:EMA(ADX,M);

    ADMA:EMA(ADX,M1);

    做多:PDI,COLORRED,LINETHICK2;

    做空:MDI,COLORCYAN,LINETHICK2;

    OMD:(ADX-2*ADMA+ADXR)/2, COLORSTICK;

    DRAWBAND(ADX,RGB(155,50,50),ADXR,RGB(0,100,50));

    STICKLINE(OMD>REF(OMD,1) AND OMD>0,0,OMD,1,0),colorred;

    STICKLINE(OMD>REF(OMD,1) AND OMD<0,0,OMD,1,0),colorgreen;

    STICKLINE(OMD<REF(OMD,1),0,OMD,1,0),COLORCBCBC0;

    STICKLINE(OMD>=0 OR OMD<=0,0,0,50,1),colorwhite;

    ADX1:ADX,colorred;

    ADXR1:ADXR,colorgreen;

    ADMA1:ADMA;

    强:IF(ADX1>=ADXR1,ADX1,DRAWNULL),colorred,LINETHICK3;

    买入:IF(OMD>0 AND OMD-REF(OMD,1)>0,30,0);

    110;

    0;

    -110;

    20,COLORRED,DOTLINE;

    50,COLORWHITE,DOTLINE;

    WWWCHNMONEYCOM:=(L+H+C+O)/4;

    DRAWICON(CROSS(PDI,MDI),做多-5,1);

    DRAWICON(CROSS(MDI,PDI),做空+5,2);
     

    多重优化DMI指标

    热门标签:

    免责声明:本站不推荐任何股票,不收会员,站内的广告不代表股票公式网的观点,目的在于传播更多信息,由此引起的一切法律责任均与本网无关,专注为大众提供股票指标、选股公式、股票入门、开户等信息,股票公式网—专业的股票学习网站!股市有风险 投资需谨慎。