• 加入收藏
    股票公式网

    您所在地位置:首页> 公式指标 > 选股公式 > 内中外艺术通道主图下载

    内中外艺术通道主图下载

    时间:2020-05-23 17:42:01 阅读:1197 编辑:

    内中外艺术通道主图源码下载:

     DRAWGBKLAST(C>0,STRIP(RGB(0,0,160),RGB(0,0,0),0));

    //{内通道}

    重心:WMA((2*C+H+L)/4,2),COLOR00FFFF,LINETHICK0;

    UPPERS: 重心*(1+2.382/100),COLOR990099,LAYER0;

    LOWERS: 重心*(1-2.382/100),COLORFF0000,LAYER0;

    //{中通道}

    VAR2:=重心*VOL;

    Var3:=(EMA(Var2,3)/EMA(VOL,3)+EMA(Var2,8)/EMA(VOL,8)+EMA(Var2,13)/EMA(VOL,13)+EMA(Var2,21)/EMA(VOL,21))/4;

    UP:=Var3*1.0809;

    DN:=Var3*0.9191;

    //{外通道}

    VAR4:=EMA(重心,19);

    LUP:=EMA(VAR4*1.119,3);

    LDN:=EMA(VAR4*0.881,3);

    UPK:=UP-UPPERS;

    FILLRGN(UPPERS,UPPERS+UPK, UP>UPPERS,RGB(230,0,50)),LAYER7;

    FILLRGN(UPPERS,UPPERS+UPK*0.8, UP>UPPERS,RGB(220,0,180)),LAYER6;

    FILLRGN(UPPERS,UPPERS+UPK*0.6, UP>UPPERS,RGB(200,0,150)),LAYER5;

    FILLRGN(UPPERS,UPPERS+UPK*0.5, UP>UPPERS,RGB(180,0,100)),LAYER4;

    FILLRGN(UPPERS,UPPERS+UPK*0.4, UP>UPPERS,RGB(150,0,180)),LAYER3;

    FILLRGN(UPPERS,UPPERS+UPK*0.2, UP>UPPERS,RGB(120,0,50)),LAYER2;

    UPL:=LUP-UP;

    FILLRGN(UP,UP+UPL, UP<LUP,RGB(80,0,80)),LAYER7;

    FILLRGN(UP,UP+UPL*0.8, UP<LUP,RGB(100,0,120)),LAYER6;

    FILLRGN(UP,UP+UPL*0.6, UP<LUP,RGB(120,0,150)),LAYER5;

    FILLRGN(UP,UP+UPL*0.5, UP<LUP,RGB(150,0,180)),LAYER4;

    FILLRGN(UP,UP+UPL*0.4, UP<LUP,RGB(180,0,220)),LAYER3;

    FILLRGN(UP,UP+UPL*0.2, UP<LUP,RGB(200,0,255)),LAYER2;

    FILLRGN(UPPERS,LOWERS, LOWERS<UPPERS,RGB(40,30,20)),LAYER7;

    UPD:=LOWERS-DN;//www.CHNmoney.com

    FILLRGN(LOWERS,LOWERS-UPD, LOWERS>DN,RGB(0,230,30)),LAYER7;

    FILLRGN(LOWERS,LOWERS-UPD*0.8, LOWERS>DN,RGB(0,200,55)),LAYER6;

    FILLRGN(LOWERS,LOWERS-UPD*0.6, LOWERS>DN,RGB(0,150,100)),LAYER5;

    FILLRGN(LOWERS,LOWERS-UPD*0.4, LOWERS>DN,RGB(0,100,100)),LAYER4;

    FILLRGN(LOWERS,LOWERS-UPD*0.2, LOWERS>DN,RGB(0,80,80)),LAYER3;

    FILLRGN(DN,DN-UPL, DN>LDN,RGB(0,80,50)),LAYER7;

    UPL:=DN-LDN;

    FILLRGN(DN,DN-UPL*0.8, DN>LDN,RGB(0,100,80)),LAYER6;

    FILLRGN(DN,DN-UPL*0.6, DN>LDN,RGB(0,120,100)),LAYER5;

    FILLRGN(DN,DN-UPL*0.4, DN>LDN,RGB(0,150,150)),LAYER4;

    FILLRGN(DN,DN-UPL*0.2, DN>LDN,RGB(0,180,180)),LAYER3;

    //{红股.绿币的趋势线}

    MA5:WMA(重心,5),COLOR00FF00,DOTLINE,LAYER0;

    PARTLINE(MA5 ,(MA5>REF(MA5,1)),RGB(255,100,0) ),linethick2,LAYER0;

    //{K线}

    STICKLINE(CLOSE>OPEN OR CLOSE=OPEN AND CLOSE>REF(CLOSE,1),LOW,HIGH,0.1,0),colorred,LAYER0;

    STICKLINE(CLOSE>OPEN OR CLOSE=OPEN AND CLOSE>REF(CLOSE,1),OPEN,CLOSE,0,0),colorred,LAYER0;

    STICKLINE(CLOSE<OPEN OR CLOSE=OPEN AND CLOSE<=REF(CLOSE,1),LOW,HIGH,0.1,0),colorcyan,LAYER0;

    STICKLINE(CLOSE<OPEN OR CLOSE=OPEN AND CLOSE<=REF(CLOSE,1),OPEN,CLOSE,0,0),colorcyan,LAYER0;

    STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR008800,LAYER0;

    STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR009900,LAYER0;

    STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00AA00,LAYER0;

    STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR00BB00,LAYER0;

    STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR00CC00,LAYER0;

    STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00DD00,LAYER0;

    STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00EE00,LAYER0;

    STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00,LAYER0;

    STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00,LAYER0;

    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLOR000066,LAYER0;

    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000088,LAYER0;

    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR0000AA,LAYER0;

    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR0000BB,LAYER0;

    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR0000CC,LAYER0;

    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000DD,LAYER0;

    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000EE,LAYER0;

    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000FF,LAYER0;

    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLOR0000FF,LAYER0;
     

    内中外艺术通道主图

    热门标签:

    免责声明:本站不推荐任何股票,不收会员,站内的广告不代表股票公式网的观点,目的在于传播更多信息,由此引起的一切法律责任均与本网无关,专注为大众提供股票指标、选股公式、股票入门、开户等信息,股票公式网—专业的股票学习网站!股市有风险 投资需谨慎。