• 加入收藏
    股票公式网

    您所在地位置:首页> 公式指标 > MACD指标 > 缠论MACD背驰偏移机会下载

    缠论MACD背驰偏移机会下载

    时间:2020-05-04 19:44:01 阅读:1441 编辑:

    缠论MACD背驰偏移机会源码下载:

    N:=13;

    M:=9;

    DU0:=CROSS(DIFF,0);

    UD0:=CROSS(0,DIFF);

    DIFF:EMA(CLOSE,12)-EMA(CLOSE,27);

    DEA:EMA(DIFF,9);

    MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;

    MACD2:=(2*(DIFF - DEA));

    STICKLINE(MACD>=0,MACD,0,4,1),COLORF00FF0;

    STICKLINE(MACD<0,MACD,0,4,1),colorwhite;

    STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,4,0 ),COLOR00aaff;

    低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;

    STICKLINE(低位金叉,0,0.08,6,0),coloryellow;

    DRAWTEXT(低位金叉,0.16,' 低位金叉'),colorwhite;

    X1:IF(diff<0,diff,0),COLOR0000FF,LINETHICK2;

    X2:IF(diff<0,0,diff),colormagenta,LINETHICK1;

    JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

    二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

    X3:IF(diff<dea,diff,dea),COLOR00ff00,linethick1;

    X4:IF(diff>dea,dea,dea),linethick1,COLORffbb11;

    STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;

    DRAWICON(二次金叉,DEA*0.9,1) ;//www.CHNmoney.com

    DRAWTEXT(二次金叉,0.2,' 二次金叉'),coloryellow;

    DU3:=REF(DU0,1);

    UD3:=REF(UD0,1);

    A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

    底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

    STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

    底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),colorred,LINETHICK4;

    DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;

    A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

    顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

    顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),colorgreen,LINETHICK4;

    DRAWTEXT(顶背离,DEA*1.2,' 顶背离'),Color00FF00;

    R1:=EMA(HHV(HIGH,500),21);

    R2:=EMA(HHV(HIGH,250),21);

    R3:=EMA(HHV(HIGH,90),21);

    DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;

    缠论MACD背驰偏移机会

    热门标签:

    免责声明:本站不推荐任何股票,不收会员,站内的广告不代表股票公式网的观点,目的在于传播更多信息,由此引起的一切法律责任均与本网无关,专注为大众提供股票指标、选股公式、股票入门、开户等信息,股票公式网—专业的股票学习网站!股市有风险 投资需谨慎。