• 加入收藏
    股票公式网

    您所在地位置:首页> 公式指标 > 选股公式 > 中枢笔判定主图下载

    中枢笔判定主图下载

    时间:2020-09-05 13:40:01 阅读:1265 编辑:

    中枢笔判定主图源码下载:

     KU1:=IF(HIGH=HHV(HIGH,3),1,0);
    KD1:=IF(LOW=LLV(LOW,3),1,0);
    UL:=IF(REF(KU1,2)=1 AND REF(KU1,1)=0
    AND KU1=0,REF(HIGH,2),REF(HIGH,2+BARSLAST(REF(KU1,2)=1
    AND REF(KU1,1)=0 AND KU1=0)));
    DL:=IF(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0,REF(LOW,2),REF(LOW,2+BARSLAST(REF(KD1,2)=1
    AND REF(KD1,1)=0 AND KD1=0)));
    HV:=H>UL AND H>REF(H,1) ;
    LV:=L<DL AND L<REF(L,1) ;
    GP:=BARSLAST(HV);
    DP:=BARSLAST(LV);
    IP:=IF(GP=0,DP,GP)>3;
    HV1:=HV AND IP AND H>=HHV(H,BARSLAST(LV));
    LV1:=LV AND IP AND L<=LLV(L,BARSLAST(HV));
    DRAWLINE(LV1,LOW,HV1, HIGH,0),coloryellow,LINETHICK2;
    DRAWLINE(HV1,HIGH,LV1, LOW,0),colormagenta,LINETHICK2;
    ///加入中枢判定
    //简化版
    N1:=10;N2:=10;DISP:=2;K:=1;
    P1:=PEAK(1,K*N1,1);
    P2:=PEAK(1,K*N1,2);
    WP1:=PEAKBARS(1,K*N1,1);
    WP2:=PEAKBARS(1,K*N1,2);
    T1:=TROUGH(2,K*N2,1);
    T2:=TROUGH(2,K*N2,2);
    WT1:=TROUGHBARS(2,K*N2,1);
    WT2:=TROUGHBARS(2,K*N2,2);
    TJ1:=P1>T1 AND P2>T2 ;
    ZD:=MAX(T1,T2);
    ZG:=MIN(P1,P2);
    LL:=MIN(T1,T2);
    HH:=MAX(P1,P2);
    TJ2:=FILTER(ZG>ZD,2);
    TJ3:=ZG=REF(ZG,BARSLAST(TJ2)) OR ZD=REF(ZD,BARSLAST(TJ2));
    TJ4:=TJ1 AND TJ2 AND NOT(TJ3);
    TJ5:=BETWEEN(ZD,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
    TJ6:=BETWEEN(ZG,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
    TJ7:=ZG>REF(ZG,REF(BARSLAST(TJ4),1)) AND ZD<REF(ZD,REF(BARSLAST(TJ4),1));
    TJ8:=TJ4 AND NOT(TJ5 OR TJ6 OR TJ7);{第一股票公式网www.chnMoNeY.com}
    ZSD:=IF(TJ8,ZD,REF(ZD,1));//,coloryellow;
    ZSG:=IF(TJ8,ZG,REF(ZG,1));//,colormagenta;
    ZSH:=IF(TJ8,HH,REF(HH,1));//,colorblue;
    ZSL:=IF(TJ8,LL,REF(LL,1));//,colorgreen;
    STICKLINE(TJ8,ZSH,ZSL,0,-1),colormagenta;
    STICKLINE(TJ8,ZSD,ZSG,IF(DISP=1,3,0),1),colormagenta;
    DRAWTEXT(DISP=2,ZSH,''),colorwhite;
    //中枢高
    中枢高:ZSG,colormagenta;
    POLYLINE(DISP=2,REF(ZSG,BARSLAST(TJ8))),CIRCLEDOT,colormagenta;
    //中枢低:
    中枢低:ZSD,coloryellow;
    POLYLINE(DISP=2,REF(ZSD,BARSLAST(TJ8))),CIRCLEDOT,coloryellow;
    //中枢最高:
    中枢最高:ZSH,colorred;
    POLYLINE(DISP=2,REF(ZSH,BARSLAST(TJ8))),POINTDOT,colorred;
    //中枢最低:
    中枢最低:ZSL,colorgreen;
    POLYLINE(DISP=2,REF(ZSL,BARSLAST(TJ8))),POINTDOT,colorgreen;
    //趋势高:
    //QSGD1:POLYLINE(DISP=3,ZIG(1,K*N1)),colorblue;
    //趋势低:
    //QSDD1:POLYLINE(DISP=3,ZIG(2,K*N2)),colorblue;
    MA5:MA(CLOSE,5),COLORFF00FF,Linethick1;
    //COLORFF00FF,LINETHICK2;
    命真好:=MA5>REF(MA5,1);
    命真坏:=MA5<REF(MA5,1);
    //判定:
    PARTLINE(MA5,命真好,coloryellow,命真坏,colorblue,MA5,COLORFF00FF),linethick3;
    //F1:IF(MA5<REF(MA5,1),MA5,NULL),colorwhite,LINETHICK2;
     

    中枢笔判定主图

    热门标签:

    免责声明:本站不推荐任何股票,不收会员,站内的广告不代表股票公式网的观点,目的在于传播更多信息,由此引起的一切法律责任均与本网无关,专注为大众提供股票指标、选股公式、股票入门、开户等信息,股票公式网—专业的股票学习网站!股市有风险 投资需谨慎。