• 加入收藏
    股票公式网

    您所在地位置:首页> 公式指标 > 选股公式 > 一直在找感觉还真不错在主图上显示股票详细信息的股票信息主图指标下载

    一直在找感觉还真不错在主图上显示股票详细信息的股票信息主图指标下载

    时间:2020-05-23 12:33:01 阅读:1562 编辑:

    一直在找感觉还真不错在主图上显示股票详细信息的股票信息主图指标

    一直在找感觉还真不错在主图上显示股票详细信息的股票信息主图指标
    一直在找感觉还真不错在主图上显示股票详细信息的股票信息主图指标
    一直在找一个在主图显示股票详细信息的源码或公式,今天这个感觉还不错,
    就是保存不住,软件开启需要重新主图叠加(谁有办法)
    MA(C,5);
    MA(C,10);
    MA(C,20);
    MA(C,30);
    {显示基本信息}
    DRAWTEXT_FIX(ISLASTBAR,0.8,0.05,1,STRCAT(STRCAT(HYBLOCK,' '),
    STRCAT(STRCAT(DYBLOCK,' '),GNBLOCK))),COLORGREEN;
    总市值:FINANCE(41)/100000000,NODRAW;
    流通市值:FINANCE(40)/100000000,NODRAW;
    获利盘比例:WINNER(C),NODRAW;
    {左侧}
    {利润同比:=STRCAT('利润同比:',CON2STR(FINANCE(43),2));
    收入同比:=STRCAT('收入同比:',CON2STR(FINANCE(44),2));
    主营利润率:=STRCAT('主营利润率:',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
    所属地域:=STRCAT('所属地域:',DYBLOCK);
    所属行业:=STRCAT('所属行业:',HYBLOCK);
    所属概念:=STRCAT('所属概念:',GNBLOCK);}
    所属风格:=STRCAT('所属风格:',FGBLOCK);
    主营业务:=STRCAT('主营业务:',EXTERNSTR(0,2));
    {DRAWTEXT_FIX(1,0.00,0.01,0,利润同比),COLORWHITE;
    DRAWTEXT_FIX(1,0.11,0.01,0,收入同比),COLORMAGENTA;
    DRAWTEXT_FIX(1,0.22,0.01,0,主营利润率),COLOR0080FF;
    DRAWTEXT_FIX(1,0.00,0.05,0,所属地域),COLORYELLOW;
    DRAWTEXT_FIX(1,0.00,0.09,0,所属行业),COLORYELLOW;
    DRAWTEXT_FIX(1,0.00,0.13,0,所属概念),COLORYELLOW;}
    DRAWTEXT_FIX(1,0.00,0.01,0,所属风格),COLORCYAN;
    DRAWTEXT_FIX(1,0.00,0.06,0,主营业务),COLORGREEN;
    {风险系数}
    X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
    X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替}
    X3:=FINANCE(23)/FINANCE(10)*3.3;
    X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
    X5:=FINANCE(20)/FINANCE(15)*0.999;
    Z值:=X1+X2+X3+X4+X5;
    DRAWTEXT_FIX(1,0.85,0.01,1,'财务预警:'),COLORRED;
    DRAWTEXT_FIX(Z值<1.2,0.838,0.11,1,' ●重 警●'),COLORLIRED;
    DRAWTEXT_FIX( BETWEEN(Z值,1.2,2.6),0.838,0.11,1,' ○轻 警○'),COLOR0099FF;
    DRAWTEXT_FIX(Z值>2.6,0.838,0.11,1,' ◎无 警◎'),COLORLIGREEN;
    {财务信息}
    市盈率1:=DYNAINFO(39);
    {净资收益率:=(FINANCE(33)/FINANCE(34)*100);}
    营业收入:=FINANCE(20)/10000;
    销售毛利率:=((FINANCE(20)-FINANCE(21))/FINANCE(20)*100);
    净利润:=FINANCE(30)/10000;
    净利润比率:=(FINANCE(30)/FINANCE(20)*100);
    主营利润率1:=(FINANCE(23)/FINANCE(20)*100);
    优质资产率:=((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19));
    {理论上越大越好但不同行业有不同标准};
    现金负债比:=(FINANCE(25)/FINANCE(15));
    {缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
    净利同增率:=FINANCE(43);
    DRAWTEXT_FIX(1,0.42,0.10,1,'市盈率:'),COLORYELLOW;
    DRAWTEXT_FIX(1,0.42,0.15,1,'收入 万元:'),COLORYELLOW;
    DRAWTEXT_FIX(1,0.42,0.20,1,'销售毛利率:'),COLORYELLOW;
    DRAWTEXT_FIX(1,0.42,0.25,1,'净利 万元:'),COLORYELLOW;
    DRAWTEXT_FIX(1,0.42,0.30,1,'净利润率 :'),COLORYELLOW;
    DRAWTEXT_FIX(1,0.42,0.35,1,'主营利润率:'),COLORYELLOW;
    DRAWTEXT_FIX(1,0.42,0.40,1,'优质资产率:'),COLORYELLOW;
    DRAWTEXT_FIX(1,0.42,0.45,1,'现金负债比:'),COLORYELLOW;
    {DRAWTEXT_FIX(1,0.42,0.75,1,'净利同增率:'),COLORYELLOW;}
    DRAWNUMBER_FIX(1,0.47,0.10,1,市盈率1),COLORWHITE;
    DRAWNUMBER_FIX(1,0.47,0.15,1,营业收入),COLORWHITE;
    DRAWNUMBER_FIX(1,0.47,0.20,1,销售毛利率),COLORWHITE;
    DRAWNUMBER_FIX(1,0.47,0.25,1,净利润),COLORWHITE;
    DRAWNUMBER_FIX(1,0.47,0.30,1,净利润比率),COLORWHITE;
    DRAWNUMBER_FIX(1,0.47,0.35,1,主营利润率1),COLORWHITE;
    DRAWNUMBER_FIX(1,0.47,0.40,1,优质资产率),COLORWHITE;
    DRAWNUMBER_FIX(1,0.47,0.45,1,现金负债比),COLORWHITE;
    {DRAWNUMBER_FIX(1,0.47,0.75,1,净利同增率),COLORWHITE;}
    {DRAWTEXT_FIX(1,0.498,0.01,1,'财务指标:'),COLORRED;}
    市净率:=ConST(DYNAINFO(7) / FINANCE(34));
    {市销率:=ConST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));}
    营收同比增:=FINANCE(44);
    每股净资产:=FINANCE(34);
    每股收益季:=ConST(FINANCE(33)/(5-FINANCE(37)));
    {每股收益年:=ConST(FINANCE(33));}
    每股现金流:=ConST((FINANCE(25)/FINANCE(1)));
    每股未分配:=ConST(FINANCE(32));
    每股公积金:=ConST(FINANCE(18));
    DRAWTEXT_FIX(1,0.54,0.10,1,'市净率 :'),COLORYELLOW;
    DRAWTEXT_FIX(1,0.54,0.15,1,'收入同比增 :'),COLORYELLOW;
    DRAWTEXT_FIX(1,0.54,0.20,1,'每股净资产:'),COLORYELLOW;
    DRAWTEXT_FIX(1,0.54,0.25,1,'净利同比增:'),COLORYELLOW;
    DRAWTEXT_FIX(1,0.54,0.30,1,'每股收益季:'),COLORYELLOW;
    {DRAWTEXT_FIX(1,0.54,0.45,1,'每股收益年:'),COLORYELLOW;}
    DRAWTEXT_FIX(1,0.54,0.35,1,'每股现金流:'),COLORYELLOW;
    DRAWTEXT_FIX(1,0.54,0.40,1,'每股未分配:'),COLORYELLOW;
    DRAWTEXT_FIX(1,0.54,0.45,1,'每股公积金:'),COLORYELLOW;
    DRAWNUMBER_FIX(1,0.57,0.10,1,市净率),COLORWHITE;
    DRAWNUMBER_FIX(1,0.57,0.15,1,营收同比增),COLORWHITE;
    DRAWNUMBER_FIX(1,0.57,0.20,1,每股净资产),COLORWHITE;
    DRAWNUMBER_FIX(1,0.57,0.25,1,净利同增率),COLORWHITE;
    DRAWNUMBER_FIX(1,0.57,0.30,1,每股收益季),COLORWHITE;
    {DRAWNUMBER_FIX(1,0.57,0.45,1,每股收益年),COLORWHITE;}
    DRAWNUMBER_FIX(1,0.57,0.35,1,每股现金流),COLORWHITE;
    DRAWNUMBER_FIX(1,0.57,0.40,1,每股未分配),COLORWHITE;
    DRAWNUMBER_FIX(1,0.57,0.45,1,每股公积金),COLORWHITE;
    {DRAWTEXT_FIX(ISLASTBAR,0.8,0.05,1,STRCAT(STRCAT('流通盘: ',CON2STR(流通市值,2)),
    '亿 总市值:'), STRCAT(STRCAT(DYBLOCK,' '),GNBLOCK))),COLORGREEN;};

    以上是,股票公式网小编为大家收集的一些学习第一股票公式网的一些指标

    热门标签:

    免责声明:本站不推荐任何股票,不收会员,站内的广告不代表股票公式网的观点,目的在于传播更多信息,由此引起的一切法律责任均与本网无关,专注为大众提供股票指标、选股公式、股票入门、开户等信息,股票公式网—专业的股票学习网站!股市有风险 投资需谨慎。