• 加入收藏
    股票公式网
    扫码关注公众号更多学习资讯

    您所在地位置:首页> 公式指标 > 选股公式 > 神算子主图附实测图也可拿来设置成副图K线使用指标下载

    神算子主图附实测图也可拿来设置成副图K线使用指标下载

    时间:2020-05-23 11:27:01 阅读:804 编辑:

    神算子主图附实测图也可拿来设置成副图K线使用指标

    DRAWGBK(1,RGB(0,0,0),RGB(0,0,0),0,'BJ1',0);
    N:=120;
    K:=BARSLAST(CURRBARSCOUNT=N);
    GD:=ConST(IF(ISLASTBAR=1,HHV(H,K),0)),NODRAW;{高点}
    DD:=ConST(IF(ISLASTBAR=1,LLV(L,K),0)),NODRAW;{低点}
    KJ:=GD-DD;{高低点差值=分区高度}
    GD4:=IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL);
    高区:IF(CURRBARSCOUNT<=N,GD,DRAWNULL),COLORRED,LINETHICK2,NODRAW;
    低区:IF(CURRBARSCOUNT<=N,DD,DRAWNULL),COLOR00FF00,LINETHICK2,NODRAW;
    平衡:=IF(CURRBARSCOUNT<=N,DD+KJ/2,DRAWNULL),COLOR00FFFF,NODRAW;
    低:IF(CURRBARSCOUNT<=N/2,DD,DRAWNULL),COLORFFFF00;
    高:IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL),COLOR00FFFF;
    支撑:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.191,DRAWNULL),COLOR00FFFF;
    强势: IF(CURRBARSCOUNT<=N/2,DD+KJ*0.382,DRAWNULL),COLORFF00FF;
    突破:IF(CURRBARSCOUNT<=N/2,DD+KJ/2,DRAWNULL),COLOR0000FF;
    警示:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.618,DRAWNULL),COLOR00FFFF;
    压力:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.809,DRAWNULL),COLOR00FF00;
    低涨:IF(CURRBARSCOUNT<=N/2,(C/LLV(LOW,K)-1)*100,DRAWNULL),COLOR0000FF,NODRAW;
    天数:BARSLAST(L=DD),COLORCYAN,NODRAW;
    顶点:IF(CURRBARSCOUNT<=N/2, ConST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORRED,CROSSDOT,NODRAW;
    低点:IF(CURRBARSCOUNT<=N/2, ConST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,CROSSDOT,NODRAW;
    STICKLINE(CCI>=200 AND H>=顶点,O,C,2,0),COLORBLUE;
    STICKLINE(CCI<=100 AND L<=低点,O,C,2,0),COLORYELLOW;
    DRAWBAND(高区,RGB(0,0,0),平衡,RGB(0,0,0));
    DRAWBAND(平衡,RGB(0,0,0),低区,RGB(0,0,0));
    DRAWBAND(高,RGB(120,100,0),压力,RGB(0,0,0));
    DRAWBAND(压力,RGB(258,58,0),警示,RGB(0,0,0));
    DRAWBAND(警示,RGB(128,58,0),突破,RGB(0,0,0));
    DRAWBAND(突破,RGB(68,0,0),强势,RGB(0,0,0));
    DRAWBAND(强势,RGB(38,0,0),支撑,RGB(0,0,0));
    DRAWBAND(支撑,RGB(38,38,38),低,RGB(0,0,0));
    STICKLINE(CURRBARSCOUNT=N/2,GD,DD,0,0),COLOR408080,NODRAW;
    STICKLINE(CURRBARSCOUNT<=N/2,支撑,支撑,2,0),COLOR1E1E1E;
    STICKLINE(CURRBARSCOUNT<=N/2,强势,强势,2,0),COLOR1E1E1E;
    STICKLINE(CURRBARSCOUNT<=N/2,突破,突破,2,0),COLOR1E1E1E;
    STICKLINE(CURRBARSCOUNT<=N/2,警示,警示,2,0),COLOR1E1E1E;
    STICKLINE(CURRBARSCOUNT<=N/2,压力,压力,2,0),COLOR1E1E1E;
    DRAWTEXT(CURRBARSCOUNT=10,压力,'压力-0.809'),COLOR00FFFF,NODRAW;
    DRAWTEXT(CURRBARSCOUNT=10,警示,'警示-0.618'),COLOR00FFFF,NODRAW;
    DRAWTEXT(CURRBARSCOUNT=10,突破,'突破-0.500'),COLOR00FFFF,NODRAW;
    DRAWTEXT(CURRBARSCOUNT=10,强势,'强势-0.382'),COLOR00FFFF,NODRAW;
    DRAWTEXT(CURRBARSCOUNT=10,支撑,'支撑-0.191'),COLOR00FFFF,NODRAW;
    DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.09,'【风险区】--高抛避险'),COLORFFFFFF;
    DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.3,'【警示区】--逢高减仓'),COLORFFFFFF;
    DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.45,'【突破区】--主力拉升'),COLORFFFFFF;
    DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.55,'【拉升区】--强势畜锐'),COLORFFFFFF;
    DRAWTEXT(CURRBARSCOUNT=N/4+5,DD+KJ/3,'【关注区】--逢低买入'),COLORFFFFFF;
    DRAWTEXT(CURRBARSCOUNT=N/4+5,DD+KJ/10,'【低吸区】--大胆买入'),COLORFFFFFF;
    第一防线:REFDATE(低,DATE),DOTLINE,COLORYELLOW,NODRAW;
    第二防线:REFDATE(支撑,DATE),DOTLINE,COLORWHITE,NODRAW;
    {今日保护价:(REF(C,2)+REF(C,1)+O)/3 ,COLORCC3299;}
    DRAWKLINE(H,O,L,C);{股票公式网-第一股票公式网 www.gupiaozhekou.com}
    AHC1:=CLOSE*VOL;
    AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);
    上轨:=1.06*AHC22,COLOR40FF00,LINETHICK1;
    下轨:=AHC22*0.94;
    {STICKLINE(上轨>下轨,上轨,下轨,5,0),COLOR555555;}
    ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
    启爆:=CROSS(C,上轨) OR CROSS(C,下轨) AND ZT;
    DRAWTEXT(启爆,L,'启爆'),COLORCYAN;
    STICKLINE(启爆,C,O,3,1),COLORWHITE;
    STICKLINE(启爆,C,O,1,0),COLORGREEN;
    STICKLINE(C>=O ,HIGH,LOW,0,1 ),COLORRED;
    STICKLINE(C>=O ,OPEN,CLOSE,3.1,0 ),COLOR000033;
    STICKLINE(C>=O,OPEN,CLOSE,2.7,0 ),COLOR000066;
    STICKLINE(C>=O ,OPEN,CLOSE,2.1,0 ),COLOR000099;
    STICKLINE(C>=O ,OPEN,CLOSE,1.5,0 ),COLOR0000CC;
    STICKLINE(C>=O ,OPEN,CLOSE,0.9,0 ),COLOR0000FF;
    STICKLINE(C>=O ,OPEN,CLOSE,0.3,0 ),COLORCC66FF;
    STICKLINE(C<O ,HIGH,LOW,0,1 ),COLORCYAN;
    STICKLINE(C<O ,OPEN,CLOSE,3.1,0 ),COLOR990000;

    STICKLINE(CLOSE<O ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
    STICKLINE(CLOSE<O ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
    STICKLINE(CLOSE<O ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
    STICKLINE(CLOSE<O ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
    STICKLINE(CLOSE<O ,OPEN,CLOSE,0.3,0 ),COLORCYAN;
    CC:IF(CURRBARSCOUNT<18,ConST(REF(C,1)),DRAWNULL),COLOR000000,NODRAW;
    止赢:1.05*CC,COLORMAGENTA,LINETHICK1;
    DRAWTEXT(ISLASTBAR,止赢,'止赢'),LINETHICK1;
    止损:0.97*CC,COLORYELLOW,LINETHICK1;
    DRAWTEXT(ISLASTBAR,止损,'止损'),LINETHICK1;
    DRAWNUMBER(ISLASTBAR ,C,C),COLORWHITE;
    AAA:=ConST(HHV(H,50));PL5:=HHV(H,45);
    F:=100*(C-REF(C,1))/REF(C,1);
    博尔:=IF(C<REF(O,1) AND F<0,1,0);
    P1:=博尔;
    量化:=IF(C<REF(O,2) AND F<0,1,0);
    P2:=量化;
    STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,3,0),COLOR0055FF;
    操作30日均线:EMA(C,30),COLORYELLOW,LINETHICK4;
    红升:IF(操作30日均线>REF(操作30日均线,1),操作30日均线,DRAWNULL),COLORRED,LINETHICK4;
    绿降:IF(操作30日均线<REF(操作30日均线,1),操作30日均线,DRAWNULL),COLOR009300,LINETHICK4;
    趋势55日线:EMA(C,55),COLORYELLOW,LINETHICK1,NODRAW;
    红升4:IF(趋势55日线>REF(趋势55日线,1),趋势55日线,DRAWNULL),COLOR0080FF,LINETHICK1;
    绿降4:IF(趋势55日线<REF(趋势55日线,1),趋势55日线,DRAWNULL),COLORFFFF00,DOTLINE,LINETHICK1;
    年线:EMA(C,250),COLORYELLOW,LINETHICK1,NODRAW;
    年红升:IF(年线>REF(年线,1),年线,DRAWNULL),COLOR8000FF,LINETHICK1;
    年绿降:IF(年线<REF(年线,1),年线,DRAWNULL),COLORFFFF00,DOTLINE,LINETHICK1;

    神算子主图附实测图也可拿来设置成副图K线使用指标

    以上是,股票公式网小编为大家收集的一些学习第一股票公式网的一些指标

    热门标签:

    免责声明:本站不推荐任何股票,不收会员,站内的广告不代表股票公式网的观点,目的在于传播更多信息,由此引起的一切法律责任均与本网无关,专注为大众提供股票指标、选股公式、股票入门、开户等信息,股票公式网—专业的股票学习网站!股市有风险 投资需谨慎。