• 加入收藏
    股票公式网
    扫码关注公众号更多学习资讯

    您所在地位置:首页> 公式指标 > 选股公式 > 通达信公式趋势比对副图无未来附贴图指标下载

    通达信公式趋势比对副图无未来附贴图指标下载

    时间:2020-08-05 18:16:01 阅读:1509 编辑:

    通达信公式趋势比对副图无未来附贴图指标

     M1:=5;
    M2:=10;
    M3:=20;{股票公式网-第一股票公式网 www.gupiaozhekou.com}
    M4:=60;
    M5:=120;
    MA1:MA(CLOSE,M1)LINETHICK1;
    MA2:MA(CLOSE,M2)LINETHICK1;
    MA3:MA(CLOSE,M3)LINETHICK2;
    MA4:MA(CLOSE,M4)LINETHICK1;
    MA5:MA(CLOSE,M5)LINETHICK1;

    STICKLINE((C-REF(C,1))/REF(C,1)>0.095 AND C=H,C,O,1,0),COLOR00FFFF;
    STICKLINE((REF(C,1)-C)/ REF(C,1) >0.097 AND C=L,C,O,1,0),COLORGREEN;
    G:=MA(C,5);
    D:=MA(C,10);
    HH:=REF(H,5)=HHV(H,11);
    LL:=REF(L,5)=LLV(L,11);
    FG01:=BACKSET(HH,6)>BACKSET(HH,5) ;
    FD01:=BACKSET(LL,6)>BACKSET(LL,5) ;
    FG02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND G>D,FG01,IF(BARSLAST(FD01)>BARSLAST(FG01),FG01,0));
    FD02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND D>G,FD01,IF(BARSLAST(FG01)>BARSLAST(FD01),FD01,0));
    FG0:=FG02 AND H=HHV(H,BARSLAST(FD02));
    FD0:=FD02 AND L=LLV(L,BARSLAST(FG02));
    GP:=IF(FG0,H,DRAWNULL),CIRCLEDOT,COLORCYAN;
    DP:=IF(FD0,L,DRAWNULL),CIRCLEDOT,COLORGREEN;
    GQ:=L>REF(H,1) AND DAY!=REF(DAY,1);
    DQ:=H<REF(L,1) AND DAY!=REF(DAY,1);
    GQL:=REF(L,BARSLAST(GQ));
    DQH:=REF(H,BARSLAST(DQ));
    FGH:=REF(H,BARSLAST(FG0));
    FGL:=REF(L,BARSLAST(FG0));
    FGH1:=REF(H,BARSLAST(FG0)+1);
    FGL1:=REF(L,BARSLAST(FG0)+1);
    FGH2:=REF(H,BARSLAST(FG0)+2);
    FGL2:=REF(L,BARSLAST(FG0)+2);
    FDH:=REF(H,BARSLAST(FD0));
    FDL:=REF(L,BARSLAST(FD0));
    FDH1:=REF(H,BARSLAST(FD0)+1);
    FDL1:=REF(L,BARSLAST(FD0)+1);
    FDH2:=REF(H,BARSLAST(FD0)+2);
    FDL2:=REF(L,BARSLAST(FD0)+2);
    FGZH:=IF(FGL<=FGL1,FGH2,FGH1);
    FGZL:=IF(FGH1<FGL,FGL,IF(FGL<=FGL1,FGL2,FGL1));
    FDZH:=IF(FDL1>FDH,FDH,IF(FDH>=FDH1,FDH2,FDH1));
    FDZL:=IF(FDH>=FDH1,FDL2,FDL1);
    FG1:=FGH>FDZH AND FG0;
    FD1:=FDL<FGZL AND FD0;
    FG:=FG1 AND FGH>FDH AND FGL>FDL AND FGL1>FDL;
    FD:=FD1 AND FDL<FGL AND FDH<FGH AND FDH1<FGH;
    BH0:=(H<=REF(H,1) AND L>=REF(L,1)) OR (H>=REF(H,1) AND L<=REF(L,1));
    BHG:=COUNT(BH0,BARSLAST(FD0));
    BHD:=COUNT(BH0,BARSLAST(FG0));
    BGQ:=COUNT(GQ,BARSLAST(FD0));
    BDQ:=COUNT(DQ,BARSLAST(FG0));
    BK0:=IF(BHG>0,BHG+2+1,IF(BHD,BHD+2+1,3));
    BK:=IF(BGQ,BK0-BGQ,IF(BDQ,BK0-BDQ,BK0));
    G1X:=(FG AND BARSLAST(FD)>BK);
    D1X:=(FD AND BARSLAST(FG)>BK);
    G1:=(FG0 AND REF(H,BARSLAST(FG0))>=REF(H,BARSLAST(G1X)) AND BARSLAST(D1X)>BARSLAST(G1X))
    OR (FG1 AND COUNT(GQ,BARSLAST(FD1))>0 AND REF(H,BARSLAST(FG1))>REF(H,BARSLAST(G1X)));
    D1:=(FD0 AND REF(L,BARSLAST(FD0))<=REF(L,BARSLAST(D1X)) AND BARSLAST(G1X)>BARSLAST(D1X))
    OR (FD1 AND COUNT(DQ,BARSLAST(FG1))>0 AND REF(L,BARSLAST(FD1))<REF(H,BARSLAST(D1X)));
    G1H:=IF(BARSLAST(D1)>BARSLAST(G1),REF(H,BARSLAST(G1)),REF(H,BARSLAST(D1))),;
    D1L:=IF(BARSLAST(G1)>BARSLAST(D1),REF(L,BARSLAST(D1)),REF(L,BARSLAST(G1)));
    G2:=G1 AND H=HHV(G1H,BARSLAST(D1)+1) AND H>REF(H,1) AND BARSLAST(D1)>BARSLAST(G1);
    D2:=D1 AND L=LLV(D1L,BARSLAST(G1)+1) AND L<REF(L,1) AND BARSLAST(G1)>BARSLAST(D1);
    G3:=G2 OR (FG0 AND REF(H,BARSLAST(FG0))>REF(H,BARSLAST(G2)) AND BARSLAST(D2)>BARSLAST(G2));
    D3:=D2 OR (FD0 AND REF(L,BARSLAST(FD0))<REF(L,BARSLAST(D2)) AND BARSLAST(G2)>BARSLAST(D2));
    GPB:=IF(G1X,H,DRAWNULL),,COLORYELLOW,LINETHICK2;
    DPB:=IF(D1X,L,DRAWNULL),CIRCLEDOT,COLORYELLOW;
    {画线}
    NN:=G3;
    UU:=D3;
    L1:DRAWLINE(UU,L,NN, H,0),COLORYELLOW,DOTLINE;
    L2:DRAWLINE(NN,H,UU, L,0),COLORWHITE,DOTLINE;
    Z1:=STRCAT(HYBLOCK,' ');
    Z2:=STRCAT(Z1,DYBLOCK);
    Z3:=STRCAT(Z2,' ');
    DRAWTEXT_FIX(ISLASTBAR,0,10,0,STRCAT(Z3,GNBLOCK)),COLOR0000FF;

    DRAWTEXT_FIX(1,0.00,0.00,0,'主题投资:')COLOR0000FF;
    DRAWTEXT_FIX(1,0.07,0.00,0,EXTERNSTR(0,1))COLOR0000FF;
    DRAWTEXT_FIX(1,0.00,0.08,0,'主营业务:')COLORFF00FF;
    DRAWTEXT_FIX(1,0.07,0.08,0,EXTERNSTR(0,2))COLORFF00FF;
    流通市值:(FINANCE(40)/100000000),NODRAW,COLORRED;
     

    通达信公式趋势比对副图无未来附贴图指标

    以上是,股票公式网小编为大家收集的一些学习第一股票公式网的一些指标

    热门标签:

    免责声明:本站不推荐任何股票,不收会员,站内的广告不代表股票公式网的观点,目的在于传播更多信息,由此引起的一切法律责任均与本网无关,专注为大众提供股票指标、选股公式、股票入门、开户等信息,股票公式网—专业的股票学习网站!股市有风险 投资需谨慎。