• 加入收藏
    股票公式网

    您所在地位置:首页> 公式指标 > 选股公式 > MACD周月MACD多周期共振副图无加密附测试图公式下载

    MACD周月MACD多周期共振副图无加密附测试图公式下载

    时间:2020-06-14 16:25:02 阅读:2598 编辑:

    MACD周月MACD多周期共振副图无加密附测试图公式

     月DIF:"MACD.DIfF#MONTH";

    月DEA:"MACD.DEA#MONTH";

    周DIF:"MACD.DIFf#WEEK";

    周DEA:"MACD.DEA#WEEK";

    FILLRGN(月DIF,月DEA,月DIF>月DEA,RGB(250,0,250),月DIF<月DEA,RGB(0,250,250));

    FILLRGN(周DIF,周DEA,周DIF>周DEA,RGB(150,50,150),周DIF<周DEA,RGB(30,200,250));

    MACD周金叉:CROSS(周DIF,周DEA)*0.3,COLORRED,LINETHICK2;

    MACD月金叉:CROSS(月DIF,月DEA)*0.4,COLORYELLOW,LINETHICK2;

    {DRAWTEXT(MACD周金叉=1,0.35,51),COLORRED;}

    DIF:EMA(CLOSE,12)-EMA(CLOSE,26);

    DEA:EMA(DIF,9);

    MACD:(DIF-DEA)*2,COLORSTICK;

    VAR2:=EMA(DIF,9);

    VAR3:=DIF>VAR2;

    VAR4:=DIF<VAR2;

    MACD:="MACD.MACD";

    PARTLINE(MACD+0.06,CROSS(DIF,DEA) AND DIF<(-0.1),RGB(255,255,0)),cIRCLEDOT,LINETHICK4;

    VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

    OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

    OBV2:=EMA(OBV1,3)-MA(OBV1,9);

    OBV3:=EMA(IF(OBV2>0,OBV2,0),3);

    MAC3:=MA(C,3);

    吸:=MACD<0 AND MACD>REF(MACD,1);

    拉:=MACD>0 AND MACD>REF(MACD,1);

    派:=MACD>0 AND MACD<REF(MACD,1);

    落:=MACD<0 AND MACD<REF(MACD,1);

    STICKLINE(吸,0,MACD,1,0),COLORRED;

    STICKLINE(拉,0,MACD,1,0),COLORRED;

    STICKLINE(派,0,MACD,1,0),COLORGREEN;

    STICKLINE(落,0,MACD,1,0),COLORWHITE;

    主力买:IF(DIF>REF(DIF,1),DIF,0),COLORRED,LINETHICK0;

    主力卖:IF(DIF<REF(DIF,1),DIF,0),COLOR00FF00,LINETHICK0;

    主力吸筹:吸,COLORYELLOW,LINETHICK0;

    主力拉升:拉,COLORRED,LINETHICK0;

    主力派送:派,COLORGREEN,LINETHICK0;

    主力砸盘:落,COLORWHITE,LINETHICK0;

    低位金叉:CROSS(DIF,DEA) AND DIF<-0.1,LINETHICK0;

    STICKLINE(低位金叉,0,0.08,6,0),COLORFF00FF;

    DRAWTEXT(低位金叉,0.16,'低位金叉'),COLORWHITE;

    JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

    二次金叉:CROSS(DIF,DEA) AND DEA<0,COLORRED,LINETHICK0;

    STICKLINE(二次金叉,0,0.06,6,0),COLORFFCC00;

    DRAWICON(二次金叉,DEA*0.9,7);

    DRAWTEXT(二次金叉,0.2,'二次金叉'),COLORYELLOW;

    A2:=BARSLAST(REF(CROSS(DIF,DEA),1));

    A3:=BARSLAST(REF(CROSS(DEA,DIF),1));

    底背离:REF(CLOSE,A2+1)>CLOSE AND DIF>REF(DIF,A2+1) AND CROSS(DIF,DEA),LINETHICK0;

    STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

    DRAWTEXT(底背离,0.12,'底背离'),COLORFF00FF;

    顶背离:=REF(CLOSE,A3+1)<CLOSE AND REF(DIF,A3+1)>DIF AND CROSS(DEA,DIF);

    DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;

    双金叉:低位金叉 AND 二次金叉,COLORYELLOW,LINETHICK0;

    三全项:低位金叉 AND 二次金叉 AND 底背离,COLORGREEN,LINETHICK0;
     

    MACD周月MACD多周期共振副图无加密附测试图公式

    热门标签:

    免责声明:本站不推荐任何股票,不收会员,站内的广告不代表股票公式网的观点,目的在于传播更多信息,由此引起的一切法律责任均与本网无关,专注为大众提供股票指标、选股公式、股票入门、开户等信息,股票公式网—专业的股票学习网站!股市有风险 投资需谨慎。