• 加入收藏
    股票公式网

    您所在地位置:首页> 公式指标 > 选股公式 > 详解成交量的趋势拐点中引用未来函数的问题公式下载 大智慧指标源码函数成交量

    详解成交量的趋势拐点中引用未来函数的问题公式下载 大智慧指标源码函数成交量

    时间:2020-10-30 15:11:03 阅读:1797 编辑:

    关于<成交量的趋势拐点>引用未来函数的问题

    原文公式:
    成交量趋势拐点源码如下
    VOLUME:VOL,VOLSTICK;
    主力启动线:MA(VOLUME,5),COLORRED,LINETHICK2;
    主力洗盘线:MA(VOLUME,35),COLORYELLOW,LINETHICK2;
    资金异动线:MA(VOLUME,135),COLORBLUE,LINETHICK2;
    出击:STICKLINE(CROSS(主力启动线,资金异动线) OR ((主力洗盘线 > 资金异动线) AND
    CROSS(主力启动线,主力洗盘线)),0,VOL,2,0),COLORYELLOW;
    启动:STICKLINE(主力启动线>REF(主力启动线,1) AND (CROSS(VOL,主力启动线) AND
    (REF(VOL,1)<REF(资金异动线,1) OR
    REF(VOL,2)<REF(资金异动线,2))),0,VOL,3,0),COLORGREEN;
    [/size][size=5][color=magenta] V1:=CLOSE/REF(CLOSE,3)>=1.1;
    V2:=BACKSET(V1,2);
    V3:=REF(CLOSE,3)*1.1;
    V4:=CROSS(C,V3);
    OK:STICKLINE((V2 AND COUNT(V2,2)=1),VOL,0,5,0),COLORRED;[/color][/size]
    [size=5]在公式紫色部分中,OK变量是画在VOL柱线上画一垂直线,基本上总能在大涨(一般如此)前一天出现指示,谓之神。但细细想来,却有造假之嫌。
    请看:V1:=CLOSE/REF(CLOSE,3)>=1.1;
    这条语句仅仅告诉我们,当日是三天前的涨幅达了10以上,V1=1;
    再看:V2:=BACKSET(V1,2);
    这条语句告诉我们,如果当日比三天前涨幅达10%以,则将昨天的V2也赋为1;
    再看:OK:STICKLINE((V2 AND COUNT(V2,2)=1),VOL,0,5,0),COLORRED;
    关键这句,绘图语句是带有未来函数的,当绘图函数调用了向前赋值语句时,其后的绘图起终点会引用向前日期的当日的数据,它是函数中唯一可以向前追溯并调用以前变量数值的函数。所以,这条语句实现的功能是:如果当天是前三天价格的110%,则在昨天的位置上画OK指示线;COUNT(V2,2)的目的是防止当天也画OK线,不然就露陷了;

    如果我们把这一条语句改为:
    IF V1=1 THEN S:=S+1;
    V2:=V1;
    OK:STICKLINE( (V2 AND S>=1),VOL,0,5,0),COLORRED;
    含义与原公式相同,却得来不同的结果,即:只有当天涨停了票,才会出现OK红线,而不是提前一天指示。
    更有意思的是,如果我们把这句改为:V2:=BACKSET(V1,3);
    那我们就可以在三天前提示买入了,呵呵。


    热门标签:

    免责声明:本站不推荐任何股票,不收会员,站内的广告不代表股票公式网的观点,目的在于传播更多信息,由此引起的一切法律责任均与本网无关,专注为大众提供股票指标、选股公式、股票入门、开户等信息,股票公式网—专业的股票学习网站!股市有风险 投资需谨慎。