• 加入收藏
    股票公式网

    您所在地位置:首页> 公式指标 > 选股公式 > 顶底早知从通达信转换而来公式下载 大智慧指标源码大智慧指标源码早知

    顶底早知从通达信转换而来公式下载 大智慧指标源码大智慧指标源码早知

    时间:2020-10-30 14:24:03 阅读:1558 编辑:

    顶底早知-版本从通达信转换而来

    大智慧公式源码:

    LC:=REF(CLOSE,1);
    RSI6:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,COLORDD55DD;
    RSI12:SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100,COLORDD8855;
    LOWV:=LLV(LOW,9);
    HIGHV:=HHV(HIGH,9);
    SRSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
    SK:EMA(SRSV,3),COLORFFFFFF;
    SD:MA(SK,3),COLOR00FFFF;
    SJ:3*SK-2*SD,COLORFFFF88;
    VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
    VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
    VAR3:=EMA(VAR2,10);
    VAR4:=LLV(LOW,33);
    VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3)/2.2;
    进场:IF(VAR5>REF(VAR5,1),VAR5,0),COLORRED;
    洗盘:IF(VAR5<REF(VAR5,1),VAR5,0),COLORGREEN;
    STICKLINE(VAR5>REF(VAR5,1),0,VAR5,3,0 ),COLOR000066;
    STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.1,0 ),COLOR0000AA;
    STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.8,0 ),COLOR0000FF;
    STICKLINE(VAR5<REF(VAR5,1),0,VAR5,3,0),COLOR006600;
    STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.1,0),COLOR00AA00;
    STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.8,0),COLOR00FF00;
    VAR21:=SMA(ABS(HIGH-VAR1),13,1)/SMA(MIN(HIGH-VAR1,0),10,1);
    VAR31:=EMA(VAR21,10);
    VAR41:=HHV(HIGH,33);
    VAR51:=EMA(IF(HIGH>=VAR41,VAR31,0),3)/2.2;
    主力拉高:IF(VAR51<REF(VAR51,1),VAR51,0),COLORYELLOW;
    STICKLINE(VAR51<REF(VAR51,1),0,VAR51,3,0),COLOR00DDDD;
    STICKLINE(VAR51<REF(VAR51,1),0,VAR51,1.1,0),COLOR00FFFF;
    出货:IF(VAR51>REF(VAR51,1),VAR51,0),COLORFF8822;
    STICKLINE(VAR51>REF(VAR51,1),0,VAR51,3,0 ),COLORFF6622;
    STICKLINE(VAR51>REF(VAR51,1),0,VAR51,1.1,0 ),COLORFF4400;
    VAR1X:=REF(LOW,1);
    VAR2X:=SMA(ABS(LOW-VAR1X),3,1)/SMA(MAX(LOW-VAR1X,0),3,1)*20;
    VAR3X:=EMA(IF(CLOSE*1.2,VAR2X*10,VAR2X/10),3);
    VAR4X:=LLV(LOW,38);
    VAR5X:=HHV(VAR3X,38);
    VAR6X:=IF(LLV(LOW,90),1,0);
    VAR7X:=EMA(IF(LOW<=VAR4X,(VAR3X+VAR5X*2)/2,0),3)/618*VAR6X;
    VAR8X:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
    VAR9X:=SMA(VAR8X,13,8);
    主力吸货:VAR7X,COLOR9966FF;
    吸筹:STICKLINE(VAR7X,0,VAR7X,0,0),COLOR9966FF;
    Y1:=SMA(ABS(L-REF(L,1)),34,1);
    Y2:=SMA(MAX(L-REF(L,1),0),34,2);
    W底:=-(EMA(IF(L<= LLV(L,34),Y1/Y2,-3),9));
    A:=-(EMA(IF(L<= LLV(L,8),Y1/Y2,-3),9));
    Y3:=SMA(ABS(H-REF(H,1)),34,1);
    Y4:=-SMA(MIN(H-REF(H,1),0),34,2);
    X:=6-(EMA(IF(H>= HHV(H,34),-Y3/Y4,3),9));
    B:=6-(EMA(IF(H>= HHV(H,8),-Y3/Y4, 3),9));
    DIFL:=EMA(V,12)-EMA(V,26);
    DIF:=EMA(C,12)-EMA(C,26);
    底BL:=DIFL>REF(DIFL,1) AND DIF<REF(DIF,1);
    顶BL:=DIFL<REF(DIFL,1) AND DIF>REF(DIF,1);
    量底:IF(((W底<3 AND W底<REF(W底,1)) OR (A<3 AND A<REF(A,1))) AND 底BL,1,0),COLOR0000FF;
    K:="SKDJ.K";
    价底:IF(((W底<3 AND W底<REF(W底,1)) OR (A<3 AND A<REF(A,1))) AND 底BL AND K<20,1,0),COLORAA55FF;
    量顶:IF(((X>3 AND X>REF(X,1)) OR (B>3 AND B>REF(B,1))) AND 顶BL,1,0),COLOR88FF88;
    价顶:IF(((X>3 AND X>REF(X,1)) OR (B>3 AND B>REF(B,1))) AND 顶BL AND K>80,1,0),COLORFFFF00;
    DRAWICON(((W底<3 AND W底<REF(W底,1)) OR (A<3 AND A<REF(A,1))) AND 底BL,10,1);
    DRAWICON(((X>3 AND X>REF(X,1)) OR (B>3 AND B>REF(B,1))) AND 顶BL,90,2);
    DRAWICON(((W底<3 AND W底<REF(W底,1)) OR (A<3 AND A<REF(A,1))) AND 底BL AND K<20,0,13);
    DRAWICON(((X>3 AND X>REF(X,1)) OR (B>3 AND B>REF(B,1))) AND 顶BL AND K>80,100,14);
    RSV0:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
    K0:=SMA(RSV0,3,1);
    D0:=SMA(K0,3,1);
    J0:=3*K0-2*D0;
    卖警:IF(COUNT(J0>=100,3)=3,90,100),COLOR008800,DOTLINE;
    买警:IF(COUNT(J0<=0,3)=3,10,0),COLOR885588,DOTLINE;
    DRAWTEXT(卖警=90 AND 卖警<REF(卖警,1),90,'卖警'),COLOR00AA00;
    DRAWTEXT(买警=10 AND 买警>REF(买警,1),15,'买警'),COLORFFFFFF;
    TJ00:=BARSLAST(REF(CROSS(K0,D0) AND REF(K0,1)<35,1));
    TJ11:=LLV(L,5)<REF(LLV(L,5),TJ00+1)*1.05 AND REF(K0,1)<55 AND (TJ00+1)<20 AND (TJ00+1)>5 AND LLV(K0,6)>REF(LLV(K0,6),TJ00+1) AND CROSS(K0,D0);
    加仓:IF(TJ11,15,0),COLOR0000FF;
    轻仓:IF(COUNT(K0<20.5,3)=3 AND (K0-D0)>REF(K0-D0,1),15,0),COLOR55FFFF;
    波高警:=COUNT(J0>=100,2)=2 AND K0>80 AND (K0-D0)<REF(K0-D0,1);
    DRAWICON(波高警,88.5,12);
    顶线:100,COLOR0000FF,DOTLINE;
    高位:85,COLOR55DD55;
    低位:15,COLOR5555DD;
    底线:0,COLORFF8800,DOTLINE;
    周KK:="KDJ.K#WEEK"(9,3,3);
    周DD:="KDJ.D#WEEK"(9,3,3);
    强弱分界:50,COLOR222222,DOTLINE;
    周KD金叉:IF(周KK>=周DD,50,0),COLOR222222;
    DRAWICON(CROSS(周KK,周DD),50,7);
    DRAWICON(CROSS(周DD,周KK),50,8);
    SK1:SK,LINETHICK1,COLORFFFFFF;
    SD1:SD,LINETHICK1,COLOR00FFFF;
    SJ1:SJ,COLORFFFF22,DOTLINE;
    卖:DRAWTEXT(CROSS(SD,SK),90,'卖↓'),COLOR22FF22;
    买:DRAWTEXT(CROSS(SK,SD),20,'买↑'),COLOR2222FF;

    通达信源码如下:
    LC:=REF(CLOSE,1);
    RSI6:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,COLORDD55DD,NODRAW;
    RSI12:SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100,COLORDD8855,NODRAW;
    DRAWBAND(RSI6,RGB(100,42,100),RSI12,RGB(20,60,100));
    LOWV:=LLV(LOW,9);
    HIGHV:=HHV(HIGH,9);
    SRSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
    SK:EMA(SRSV,3),COLORFFFFFF,NODRAW;
    SD:MA(SK,3),COLOR00FFFF,NODRAW;
    SJ:3*SK-2*SD,COLORFFFF88,NODRAW;
    VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
    VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
    VAR3:=EMA(VAR2,10);
    VAR4:=LLV(LOW,33);
    VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3)/2.2;
    进场:IF(VAR5>REF(VAR5,1),VAR5,0),COLORRED,NODRAW;
    洗盘:IF(VAR5<REF(VAR5,1),VAR5,0),COLORGREEN,NODRAW;
    STICKLINE(VAR5>REF(VAR5,1),0,VAR5,3,0 ),COLOR000066;
    STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.1,0 ),COLOR0000AA;
    STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.8,0 ),COLOR0000FF;
    STICKLINE(VAR5<REF(VAR5,1),0,VAR5,3,0),COLOR006600;
    STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.1,0),COLOR00AA00;
    STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.8,0),COLOR00FF00;
    VAR21:=SMA(ABS(HIGH-VAR1),13,1)/SMA(MIN(HIGH-VAR1,0),10,1);
    VAR31:=EMA(VAR21,10);
    VAR41:=HHV(HIGH,33);
    VAR51:=EMA(IF(HIGH>=VAR41,VAR31,0),3)/2.2;
    主力拉高:IF(VAR51<REF(VAR51,1),VAR51,0),COLORYELLOW,NODRAW;
    STICKLINE(VAR51<REF(VAR51,1),0,VAR51,3,0),COLOR00DDDD;
    STICKLINE(VAR51<REF(VAR51,1),0,VAR51,1.1,0),COLOR00FFFF;
    出货:IF(VAR51>REF(VAR51,1),VAR51,0),COLORFF8822,NODRAW;
    STICKLINE(VAR51>REF(VAR51,1),0,VAR51,3,0 ),COLORFF6622;
    STICKLINE(VAR51>REF(VAR51,1),0,VAR51,1.1,0 ),COLORFF4400;
    VAR1X:=REF(LOW,1);
    VAR2X:=SMA(ABS(LOW-VAR1X),3,1)/SMA(MAX(LOW-VAR1X,0),3,1)*20;
    VAR3X:=EMA(IF(CLOSE*1.2,VAR2X*10,VAR2X/10),3);
    VAR4X:=LLV(LOW,38);
    VAR5X:=HHV(VAR3X,38);
    VAR6X:=IF(LLV(LOW,90),1,0);
    VAR7X:=EMA(IF(LOW<=VAR4X,(VAR3X+VAR5X*2)/2,0),3)/618*VAR6X;
    VAR8X:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
    VAR9X:=SMA(VAR8X,13,8);
    主力吸货:VAR7X,COLOR9966FF,NODRAW;
    吸筹:STICKLINE(VAR7X,0,VAR7X,0,0),COLOR9966FF;
    Y1:=SMA(ABS(L-REF(L,1)),34,1);
    Y2:=SMA(MAX(L-REF(L,1),0),34,2);
    W底:=-(EMA(IF(L<= LLV(L,34),Y1/Y2,-3),9)),COLORFF55FF,NODRAW;
    A:=-(EMA(IF(L<= LLV(L,8),Y1/Y2,-3),9)),COLOR66FFFF,NODRAW;
    Y3:=SMA(ABS(H-REF(H,1)),34,1);
    Y4:=-SMA(MIN(H-REF(H,1),0),34,2);
    X:=6-(EMA(IF(H>= HHV(H,34),-Y3/Y4,3),9)),COLORRED,LINETHICK1;
    B:=6-(EMA(IF(H>= HHV(H,8),-Y3/Y4, 3),9)),COLOR66CC33,NODRAW;
    DIFL:=EMA(V,12)-EMA(V,26);
    DIF:=EMA(C,12)-EMA(C,26);
    底BL:=DIFL>REF(DIFL,1) AND DIF<REF(DIF,1);
    顶BL:=DIFL<REF(DIFL,1) AND DIF>REF(DIF,1);
    量底:IF(((W底<3 AND W底<REF(W底,1)) OR (A<3 AND A<REF(A,1))) AND 底BL,1,0),COLOR0000FF,NODRAW;
    K:="SKDJ.K";
    价底:IF(((W底<3 AND W底<REF(W底,1)) OR (A<3 AND A<REF(A,1))) AND 底BL AND K<20,1,0),COLORAA55FF,NODRAW;
    量顶:IF(((X>3 AND X>REF(X,1)) OR (B>3 AND B>REF(B,1))) AND 顶BL,1,0),COLOR88FF88,NODRAW;
    价顶:IF(((X>3 AND X>REF(X,1)) OR (B>3 AND B>REF(B,1))) AND 顶BL AND K>80,1,0),COLORFFFF00,NODRAW;
    DRAWICON(((W底<3 AND W底<REF(W底,1)) OR (A<3 AND A<REF(A,1))) AND 底BL,10,1);
    DRAWICON(((X>3 AND X>REF(X,1)) OR (B>3 AND B>REF(B,1))) AND 顶BL,90,2);
    DRAWICON(((W底<3 AND W底<REF(W底,1)) OR (A<3 AND A<REF(A,1))) AND 底BL AND K<20,0,13);
    DRAWICON(((X>3 AND X>REF(X,1)) OR (B>3 AND B>REF(B,1))) AND 顶BL AND K>80,100,14);
    RSV0:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
    K0:=SMA(RSV0,3,1);
    D0:=SMA(K0,3,1);
    J0:=3*K0-2*D0;
    卖警:IF(COUNT(J0>=100,3)=3,90,100),COLOR008800,DOTLINE;
    买警:IF(COUNT(J0<=0,3)=3,10,0),COLOR885588,DOTLINE;
    DRAWTEXT(卖警=90 AND 卖警<REF(卖警,1),90,'卖警'),COLOR00AA00;
    DRAWTEXT(买警=10 AND 买警>REF(买警,1),15,'买警'),COLORFFFFFF;
    TJ00:=BARSLAST(REF(CROSS(K0,D0) AND REF(K0,1)<35,1));
    TJ11:=LLV(L,5)<REF(LLV(L,5),TJ00+1)*1.05 AND REF(K0,1)<55 AND (TJ00+1)<20 AND (TJ00+1)>5 AND LLV(K0,6)>REF(LLV(K0,6),TJ00+1) AND CROSS(K0,D0);
    加仓:IF(TJ11,15,0),COLOR0000FF;
    轻仓:IF(COUNT(K0<20.5,3)=3 AND (K0-D0)>REF(K0-D0,1),15,0),COLOR55FFFF;
    波高警:=COUNT(J0>=100,2)=2 AND K0>80 AND (K0-D0)<REF(K0-D0,1);
    DRAWICON(波高警,88.5,12);
    顶线:100,COLOR0000FF,DOTLINE;
    高位:85,COLOR55DD55;
    低位:15,COLOR5555DD;
    底线:0,COLORFF8800,DOTLINE;
    周KK:="KDJ.K#WEEK"(9,3,3);
    周DD:="KDJ.D#WEEK"(9,3,3);
    强弱分界:50,COLOR222222,DOTLINE;
    周KD金叉:IF(周KK>=周DD,50,DRAWNULL),COLOR222222;
    DRAWICON(CROSS(周KK,周DD),50,7);
    DRAWICON(CROSS(周DD,周KK),50,8);
    SK1:SK,LINETHICK1,COLORFFFFFF;
    SD1:SD,LINETHICK1,COLOR00FFFF;
    SJ1:SJ,COLORFFFF22,DOTLINE;
    卖:DRAWTEXT(CROSS(SD,SK),90,'卖↓'),COLOR22FF22;
    买:DRAWTEXT(CROSS(SK,SD),20,'买↑'),COLOR2222FF;

    附件里提供的是大智慧的公式,没通达信公式


    热门标签:

    免责声明:本站不推荐任何股票,不收会员,站内的广告不代表股票公式网的观点,目的在于传播更多信息,由此引起的一切法律责任均与本网无关,专注为大众提供股票指标、选股公式、股票入门、开户等信息,股票公式网—专业的股票学习网站!股市有风险 投资需谨慎。