• 加入收藏
    股票公式网
    扫码关注公众号更多学习资讯

    您所在地位置:首页> 公式指标 > 选股公式 > 把【CYW和OBV】添加在分时主图上【DZH】(主图源码.实测图.用法说明.附贴图)公式下载 大智慧指标源码图上加在

    把【CYW和OBV】添加在分时主图上【DZH】(主图源码.实测图.用法说明.附贴图)公式下载 大智慧指标源码图上加在

    时间:2020-09-15 19:44:01 阅读:1945 编辑:

    把【CYW和OBV】添加在分时主图上【DZH】(主图源码.实测图.用法说明.附贴图)

    把【CYW和OBV】添加在分时主图上.能够充分说明量价的关联.看清楚成交量和价格涨跌的关系因为【CYW和DBV】都是由量价元素编辑的公式.放在主图是可以一目了然.由于坐标的原因我们设置了参数你可i以默认参数k=1.p=1.实际使用是可按需要调整甚至可以是零点几.要是不想看时设置为k=0. p=0.
    ======================================================================
    INPUT:K(1,0,20),P(1,0,20);
    DRAWTEXTREL(0,10,'【CYW:K='+K+':OBV:P='+P+':0不显示】'),COLOR00FFFF,LINETHICK2;
    DRAWTEXTabs(490,5,'【大盘指数:'+NUMTOSTRN("05引.大盘指数#DAY",2)+'】【大盘涨跌:'+NUMTOSTRN("05引.大盘涨跌#DAY",2)+'】【大盘涨幅:'+NUMTOSTRN("05引.大盘涨幅#DAY",2)+'%】'),LINETHICK1,Color00ffFF,LAYER0;
    DRAWTEXTABS(500,20,'【涨家数:'+NUMTOSTRN(DYNAINFO(69),0)+ '】'),COLOR0000ff,LINETHICK1;
    DRAWTEXTABS(625,20,'【平家数:'+NUMTOSTRN(DYNAINFO(71),0)+ '】'),COLOR00FFff,LINETHICK1;
    DRAWTEXTABS(740,20,'【跌家数:'+NUMTOSTRN(DYNAINFO(70),0)+ '】'),COLOR00ff00,LINETHICK1;
    DRAWRECTABS(490,35 ,490+(DYNAINFO(69)+DYNAINFO(71)+DYNAINFO(70))/2.59,42, rgb(0,255,0)),COLOR00ff00,LAYER4;
    DRAWRECTABS(490,35 ,490+(DYNAINFO(69)+DYNAINFO(71))/2.59 ,42, rgb(255,255,0)),COLOR00FFFF,LAYER3;
    DRAWRECTABS(490,35 ,490+(DYNAINFO(69))/2.5,42, rgb(255,0,0)),COLOR0000ff,LAYER2;
    主动买D:DYNAINFO(23),Color0000ff,PRECIS0,linethick0;
    主动卖D:DYNAINFO(22),Color00ff00,PRECIS0,linethick0;
    DRAWRECTABS(490,60 ,490+(主动买D+主动卖D)/(主动买D+主动卖D)*370,67, rgb(0,255,0)),COLOR00ff00,LAYER4;
    DRAWRECTABS(490,60 ,490+(主动买D)/(主动买D+主动卖D)*370 ,67, rgb(255,0,0)),COLOR0077FF,LAYER3;
    DRAWTEXTabs(520,45,'【外盘买:'+NUMTOSTRN(主动买D/(主动买D+主动卖D)*100,1)+'%】' ),LINETHICK2,Color0000FF,LAYER0;
    DRAWTEXTabs(690,45,'【内盘卖:'+NUMTOSTRN(主动卖D/(主动买D+主动卖D)*100,1)+'%】' ),LINETHICK2,Color00FF00,LAYER0;
    DRAWTEXTABS(520,68,IFS((主动买D-主动卖D) >= 0,'【外盘买-内盘卖▄ '+NUMTOSTRN(主动买D-主动卖D,0)+'手】','')),linethick4,color0077FF;
    DRAWTEXTABS(520,68,IFS((主动买D-主动卖D) < 0,'【外盘买-内盘卖▄ '+NUMTOSTRN(主动买D-主动卖D,0)+'手】','')),linethick4,color00FF00;
    DYNAINFO(3),COLOR0077ff,DOTLINE,layer0;
    {均线}
    tt:=BARSCOUNT(C);
    zz:=SUM(AMOUNT,tt)/SUM(VOL*100,tt);
    zz1:=BETWEEN(C/zz,1.05,0.95);
    均线:IF(zz1=0,MA(C,TT),zz),COLOR00ffFF,linethick1,LAYER0;
    {最高.最低}
    H1:hhvall(hhv(C,0)),COLOR7077FF,CROSSDOT,LINETHICK1;
    L1:llvall(llv(C,0)),COLOR00FF00,CROSSDOT,LINETHICK1;
    DRAWTEXT(barstatus=2,DYNAINFO(5),' 最高:'+NUMTOSTRN(DYNAINFO(5),2)+'元'+NUMTOSTRN(100*(DYNAINFO(5)/DYNAINFO(3)-1),2)+'%'),linethick1,ALIGN0,VALIGN2,ColorFF00ff;
    DRAWTEXT(barstatus=2,DYNAINFO(6),' 最低:'+NUMTOSTRN(DYNAINFO(6),2)+'元'+NUMTOSTRN(100*(DYNAINFO(6)/DYNAINFO(3)-1),2)+'%'),linethick1,ALIGN0,VALIGN2,colorgreen;
    P1:=H1-L1;
    阻力:L1+P1*7/8,COLOR00FF00;
    支撑:L1+P1*0.5/8,COLOR00FF00;
    FILLRGN(支撑,阻力,支撑<阻力,RGB(0,0,200)),LINETHICK2,LAYER6;

    现价:CLOSE,COLOR00FFFF,LINETHICK2,LAYER0;
    DRAWTEXT(barstatus=2,DYNAINFO(7),'___'+NUMTOSTRN(DYNAINFO(7),2)+'元.委比:'+NUMTOSTRN(DYNAINFO(15)*100,0)+'%'),ALIGN0,VALIGN2,color00ffFF,LINETHICK4;
    DRAWTEXT(LonGCROSS(支撑,现价,2),支撑*1.001,'★'),COLOR00FF00,LINETHICK2;
    DRAWTEXT(LonGCROSS(现价,阻力,2),现价,'★'),COLORRED,LINETHICK2;
    DRAWTEXT(TIME=100000,C+0.01, NUMTOSTR(C)),Color00ffFF,LINETHICK3,align0;
    分钟数30:(TIME0=36000),PRECIS0,linethick0;
    VERTLINE(分钟数30,2),COLOR00FF00,LAYER4;
    {叠加大盘}
    TC:=STRCMP(STRLEFt(MARKETLABEL,2),'SZ');
    DPSH:="SH000001$CLOSE"/HHV(STKINDI('SH000001','05引.RC#DAY'),0);
    DPSZ:="399001$CLOSE"/HHV(STKINDI('399001','05引.RC#DAY'),0);
    DPC:=IF(INBLOCK('A股板块'),DYNAINFO(3)*IF(C=0,DPSZ,DPSH),C);
    POLYLINE(C>0,DPC),COLOR0000FF,LAYER0,linethick2;
    {CYW}
    YB:(L1+P1*0.5),COLORFF9900;
    STICKLINE(CYW>=0,YB,YB+CYW*K,2,0 ),Color0000ff;
    STICKLINE(CYW<0,YB,YB+CYW*K,2,0 ),Color00FF00;
    {OBV}
    OBVJ:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);
    VA:=OBVJ/100000*P;
    F:L1-P1*0.5;
    STICKLINE(OBVJ>=0,F,F+VA,4,0 ),Color0000ff;
    STICKLINE(OBVJ<0,F,F-VA,4,0 ),Color00FF00;
    FILLRGN(F,L1,F<L1,RGB(60,0,60)),LINETHICK2,LAYER7;


    把CYW和OBV添加在分时主图上

    热门标签:

    免责声明:本站不推荐任何股票,不收会员,站内的广告不代表股票公式网的观点,目的在于传播更多信息,由此引起的一切法律责任均与本网无关,专注为大众提供股票指标、选股公式、股票入门、开户等信息,股票公式网—专业的股票学习网站!股市有风险 投资需谨慎。